Chapter 5-Exercise D
EE-EO Troubleshoot Windows Issues
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Troubleshoot
Windows Issues

Instructor Led Training
Chapter 5 — Exercise D

Topics include:

= Start, Sop and Restart Services

= Change the Location of the Print Spooler Folder
» Review System Performance

= Review Error Messages in the Event Viewer

* Check the Free Space on the Hard Drive

» Configure the Windows Firewall

» Set Printer Permissions
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Start, Stop and Restart Services

Symptoms:

1. Users are unable to print and the Print spooler folder is filling up.

2. CAS server is not tracking transactions.

3. No scheduled events are occurring.

4. Equitrac System Manager is unable to connect to CAS or the database.
Resolution:

P Crarte
1. Click the button and then click Administrative Tools>Services; the

Services dialog box appears.

NOTE: Depending on the operating system and database in use, additional services than those
shown below may also be required to run. Please refer to your third-party documentation to
determine which services are necessary for your environment.

B, Gepyices
File  Action  Wew Help
o= |HRBER2E >0
% Services (Local) Mame / | Description | Skatus | Skartup T... | Log On As
%EQ DCE Service Equitrac De...  Starked Automatic Sadministrator
%EQ CME Service Equitrac De...  Starked Aukomatic Sddministrator
%EQ DRE Service Equitrac Doc,,,  Started Automatic Aadriniskrator
%EQ Scheduler Service Equitrac Sch... Started Automatic Aadriniskrator
%Event Log Enables eve,,. Started Automatic Local Swskem
%F‘rint Sponler Manages all ...  Started Automatic Local Swskem

2. To manually start a service that is not running, right-click the service and click Start; the
Service Control dialog box appears. The dialog box automatically closes when the service
has successfully started.

NOTE: If there is a dependent service running, a confirmation dialog box appears listing the
dependent services. Click the | button to proceed with the Start process.
However, if you click the Mo button, the Start process terminates. Neither the
selected nor dependent services start.

3. To manually stop a service that is running, right-click the service and click Stop; the Service
Control dialog box appears. The dialog box automatically closes when the service has
successfully stopped.
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dependent services. Click the s | button to proceed with the Stop process.

However, if you click the Ll button, the Stop process terminates. Neither the
selected nor dependent services stop.

If you choose to stop then start a service, any dependent services may not automatically start;
you will need to manually start the dependent services individually.

To manually restart a service that is currently running, right-click the service and click
Restart; the Service Control dialog box appears. The dialog box automatically closes when
the service and all dependent services have successfully restarted. When restarting a running
service, any dependent services ARE also automatically stopped and restarted; there is no
need to manually restart dependent services.

dependent services. Click the | button to proceed with the Restart process.

However, if you click the Mo button, the Restart process terminates. Neither the

selected nor dependent services are stopped or restarted.

Exercise:

1. In the Services dialog box, restart the Print Spooler service.

2. Click the ﬂ button to close the Services window.
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Change the Location of the Print Spooler Folder

Symptom:

The hard drive on the print server is filling up. As your operating system partition (usually the
C:\ drive) begins to fill up, your operating system begins to slow down and eventually stops
responding when it becomes full.

Resolution:

.—.:.'_"
1. Click the B Siefk button and then click Printers and Faxes; the Printers and Faxes
window appears.

% Printers and Faxes

File Edit Miew Favarites Toaols  Help

) Back -~ €3 - (¥ | ' Search | Folders | & X E) | [
Address | Printers and Faxes

Ty "l_\'} ProEWw "'1_\!, PrriZolar
E‘i_z;g Add Prinker [:" ! o [“" i 0
: Ready Ready

I L 0 PrSecFL Temp
‘,‘1_\'} ProfFrsFL -I"_d__l_ Dm B \:\_'1 o

= 5
M Ready .. ﬁgﬁ Ready ££§ Paused

2. Ensure that there is no printer icon selected.

3. Click File>Server Properties; the Print Server Properties dialog box appears.

&;_ Print Server Properties ilil

Forrris I Parts I Drivers  Advanced |

@ 2003EQUITRACC

Spoal folder: IE:"-.WIND WS hapstern 32 apoal PRIN TERS]

4. Click the Advanced tab.
In the Spool folder field, type the path to the new location.

6. Click the button to save the changes.

7. Click the ﬂ button to close the Print Server Properties dialog box.
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Review System Performance

Symptom:

Server appears to be running slowly.

Resolution:
1. Right-click the Windows Taskbar and then click Task Manager.

El windows Task Manager - |I:I|£|

File Cptions Yew Help

| Metwarking I Lisers I

—CPU Usage Histary

—PF Usage —Page File Usage History

2. Review the graph in the CPU Usage History section. If the graph is majorly in the top
quarter of the graph (for example, consistently above 85%), it is recommended that you
reevaluate your hardware.

3. Review the graph in the Page File usage History section. If the graph is majorly in the top
quarter of the graph, it is recommended that you increase the amount of RAM on the server.

) 14 Start ) . .

4. Click the . : button and then click Administrative Tools>Performance; the
Performance window opens.
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NOTE: The Performance Monitor is similar to Task Manager; however, it can be configured to
monitor and graph more objects and counters. This can assist in identifying the cause of a
slowness issue on the server.

(& Performance I ]
@ File Action Mjew  Favorites  wWindow  Help ;lilﬂ
- | Bn @
Dgn;?fl:t:riuhzunitur —I QI W—I I_u Q sl e H E @ﬂ 0 = @
ﬁ Perfarmance Logs and Alerts 100
g0
60
40
20
1]

Lask 44,961 Average J2.220  Minirgr

I:I.I:II:I

776,994 Duration 1:40

Mazirnurn

1.000

1aa....
1.000

Counker

Avg, Dlstu... _
% Processor,., _

Mernory
Pheysic, ..
Proces,..

'I,'I,ZIIIIZISEQLII y
W\ 2003EQUL,.

5. Top modify the objects and counters,

click the il button on the toolbar; the
Add Counters dialog box appears.

6. Adjust the various settings to monitor the
servers, objects and counters to assist you
in indentifying the cause of the slowness.

7. Click the 1 button after
defining each Object and Counter
combination.

8. Click the button when

finished; the system begins monitoring
immediately.

Add Counters

" Usze local computer counters

2=

%" Select counters from computer;

[442003E QUITRACC |

Performance objeck:

IF'ru:u:essu:ur ﬂ

&l counters

 allinstances

* Select counters from list: &+ Select instances from list:

Add Evplain |

Cloze

i
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Review Error Messages in the Event Viewer

Symptom:
1. An error message appears on the monitor.

2. Unexpected behavior is occurring.

Resolution:

o start - . .
1. Click the B button and then click Administrative Tools>Event Viewer; the
Event Viewer window appears.

H Event Yiewer

File  Action Mjew Help

= |m B @

Security
Swskem
28| Internet Explorer

NOTE: The list of log files might vary, depending on the configuration of your server.
2. Left-click the log file in the left pane (for example, Application); the events associated with
the log file appear in the right pane.

3. Review the events listed. An in the Type column indicates a problem that needs
immediate attention.

System 30

Type Dake Tirne Source
@Information Zi4/2003 95603 AWM W3ZTime
@Information 2042003 9:86:01 AWM LPDEYWC
@Information Zi4/2008 9:85:59 AM  AeLookup3ve
@Information 214/2008 955:55 AM DCOM
@Information 2/4/2008 955:55 AM eventlog
@Information 2i4/z2008 9:55:55 AM  eventlog
QError Zi4/2003 9:55:55 Ak ewventlog

@ Irformation  1/24/2008 12:27:30PM  Prirk
B Irformation  1/242008 12:27:29PM  Prirt

@Information 1/24)2008 12:27:29 PM  Prink
@Information 1/24)z008 12:27:28 PM  Prink
QError 1f24)z008 12:26:57 PM  Print
QError 1/2412005 12:26:51 PM Prink
QError 1/2412005 12:26:47 PM Prink
QError 1/24)2005 12:26:47 PM Prink
@Information 1/24)2008 12126026 PM Prink

@Information 12412008 12:26020 PM  Prink
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4. To display the details of an event, double-click the event in the right pane; the Event

D ate:
Time:
Type:

I zer:

Computer: EQSERWE R

Dezcrption:

Properties dialog box opens.

Event Prope

Ewvent |

2l x|

1/29/2008  Source:  EQ Accounting Server + |
10:29:51 Ak Categony:  Server

Error Event[D: 8 + |
EQSERYER:=MNEQService

Function 'EQCASService: eqlAS Servicelnitialize' failed. EnmCode=525
[Ox200] Errh 2g="CheckODBCR ezult: database communication erar.
SOLEror="TMicrozof[ODEC SAL Server Driver]Timeout expired’
SALState="HY'TO00' SQLM ativeE mor=[0',

NOTE: By default, the most recent events are listed at the top of the list. However, a single issue
might result in multiple events being recorded. It is recommended that you review items within the
suspected time frame in which the issue occurred, oldest to most recent.

5. The ;‘ button in the Event Properties window allows you to view the event listed

immediately above (which happened after the open event); the LI button allows you to
view the events below (which happened before the open event).

The button allows you to copy the information in the dialog box to the clipboard.
This information can then be pasted into another application, such as an email message.

For clarification on the significance, impact, or resolution of the error message, refer to the
vendor’s website or use www.Google.com to search for information on the specific error

message.
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Check the Free Space on the Hard Drive

Symptom:

Error message appears indicating that the Print spooler or database is running low on disk space.

Resolution:

1. Double-click the My Computer icon, right-click the hard drive in question, and then left-
click Properties.

2. Note the free space available (pink).

i Local Disk (C:) Properties x|

Security | Previous Versions | Quota
General | Tools I Hardware I Sharing
& |
Type: Local Digk

File system: MTFS

. |zed space: 87,093,989, 376 bytes 811GBE
. Free space: 72945 967 104 bytes 67 9GE
Capacity: 160,039,956.430 bytes 149 GB

Drive C- Digk: Cleanup |
3. Click the button to close the Properties dialog box.

4. Click the ﬂ button to close the My Computer window.
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Configure the Windows Firewall

Symptom:

Network communication is failing between servers and/or devices.

Resolution:

:y Start
1. Click the B button and then click Control Panel>Windows firewall; the

Windows Firewall dialog box appears.

== Windows Firewall |

General | E xceptions I Advanced I

rour ot protected: Firewall

Wwindows Firewall helps protect pour computer by preventing unauthonized users
from gaining access to your computer through the Internet or a network.

@ o

Thiz zetting block s all outside sources from connecting to this
carnputer, with the exception of thoze selected an the Exceptions tab.

[~ Don't allow exceplions

Select thiz when you connect to public networks in lezs zecure
lazations, such as airports. ou will nob be natified when Windows
Firewall blocks programsz. Selections on the Exceptions tab will be
ignored.

@ C o

Avoid using this setting. Tuming off Windomws Firewall may make this
computer mare vulnerable bo virdses and intruders,

Far information, see the Microsoft Web site,

ok I Cancel |

2. Ifthe On radio button is selected, ensure that the Don’t allow exceptions check box is NOT
selected.

3. Click the Exceptions tab.
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When you add a program to the exceptions list, Windows Firewall dynamically opens
(unblocks) and closes (blocks) the ports required by the program. When a program is running
and listening for incoming traffic, Windows Firewall opens the required ports; when the
program is not running or listening for incoming traffic, Windows Firewall closes the ports.
As a result of this dynamic behavior, adding programs to the exceptions list is the
recommended method for allowing unsolicited incoming traffic through the Windows
Firewall. In some instances, if you cannot add a program or system service to the exceptions
list, you must determine which specific port or ports the program or system service uses and
then add the port or ports to the Windows Firewall exceptions list.

. Add P . . .
4. Click the ﬂl button, to add the required programs or services to the Exceptions rule.

5. Click the button to locate each of the following Equitrac and SQL service programs:

C:\Program Files\Equitrac\Express\Accounting Service\EQCASService.exe
C:\Program Files\Equitrac\Express\Device Control Engine\EQDCEService.exe
C:\Program Files\Equitrac\Express\Device Monitoring Engine\EQDMEService.exe
C:\Program Files\Equitrac\Express\Document Routing Engine\EQDREService.exe
C:\Program Files\Microsoft SQL Server\90\Shared\sqlwriter.exe

C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe

e Or add the exception by port numbers (1234, 1433, 2910, 2938, 2939, 2941, 2942,

respectively)
6. Click the button, to select the program.
7. Click %10 add the x
program to the list. General Exceptians | Advanced |
8. Add each program listed above “windows Firewall is blocking incoming network. connections, except for the
programs and zervices selected below, Adding exceptions allows some prograns
Separately. to work better but might increase your security risk.
; _
9. Click the button when Programs and Services:
finished. M ame -
EQCASService exe
EQDCEService. axe
EQDMEService exe
EQDREService exe

E quitrac Express Manager
File and Printer Sharing
[ Remote Desktop
zqlbrovezer exe
salserve.exe

[ UPHP Framework, ;I

Add Program. .. Add Paort.... Edit... Delete |

Iv' Dizplay a notification when Windows Firewall blocks a program

Cancel |
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Set Printer Permissions

Symptom:

Users receive an error message indicating that they are denied access to print to the specified
printer, or they are unable to delete there print jobs.

Permissions Overview

e Print - By default, each user can print, cancel, pause, or restart documents or files
that they send to a printer.

e Manage documents - If you have this permission, you can manage all jobs for a
printer that are waiting in the print queue, including documents or files that are being
printed by other users.

e Manage printers - This permission allows you to rename, delete, share, and choose
preferences for the printer. It also allows you to choose printer permissions for other
users and to manage all jobs for the printer. Members of the administrator group for a
computer have permission to manage printers by default.

Resolution:

—_ .
1. Click the IS

2. Right-click the printer to which the user is denied access, and then clicks Properties.
3. Click the Security Tab.

button and then click Printers and Faxes.

e The Administrators group should have the following rights:
Allow — Print
Allow - Manage Printers
Allow - Manage Documents

e The CREATOR OWNER group should have the following rights:
Allow - Manage Documents

e Add the group of user who needs access to print to the selected printer and grant the
following rights:

Allow — Print
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